Back to overview
Downtime
DigiGuard is currently offline
Mar 26 at 10:12pm MDT
Affected services
DigiGuard
Resolved
Mar 26 at 10:28pm MDT
DigiGuard is now back online.
Affected services
Updated
Mar 26 at 10:23pm MDT
DigiGuard is slowly coming back online
Affected services
Updated
Mar 26 at 10:18pm MDT
We have found the issue. It should be resolved shortly.
Affected services
Created
Mar 26 at 10:12pm MDT
We are currently unable to access your photos inside of DigiGuard. We are working to resolve this as soon as possible. Your photos will not be lost during this process.
Affected services