Back to overview
Degraded
Issues with logging in to DigiGallery with a password
Dec 02 at 03:29pm MST
Affected services
DigiGallery (last_name_order_number.nailldigitizing.com)
Resolved
Dec 03 at 01:51pm MST
We have resolved the issue. If you are having issues, or if it says "Incorrect Password," please wait a couple of minutes, and check your password. If you are still having issues, please contact us.
Affected services
Updated
Dec 02 at 07:35pm MST
We have identified the issue as only occurring on mobile.
Affected services
Created
Dec 02 at 03:29pm MST
When logging into the DigiGallery, it may say "Incorrect Password," even when you entered the right password. We are currently investigating the issue.
Affected services